CVE-2011-2984

NameCVE-2011-2984
DescriptionMozilla Firefox before 3.6.20, SeaMonkey 2.x, Thunderbird 3.x before 3.1.12, and possibly other products does not properly handle the dropping of a tab element, which allows remote attackers to execute arbitrary JavaScript code with chrome privileges by establishing a content area and registering for drop events.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2295-1, DSA-2296-1, DSA-2297-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.1.0-1~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.1.0-1~deb8u1fixed
stretch1:45.1.0-1fixed
sid1:45.2.0-2fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-5high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-7highDSA-2295-1
icedovesource(unstable)3.1.12-1high
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze4highDSA-2297-1
iceweaselsource(unstable)6.0-1high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-9highDSA-2296-1
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-13highDSA-2296-1

Notes

[lenny] - xulrunner <not-affected> (Only affects Firefox >= 3.5)
[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems