CVE-2011-2998

NameCVE-2011-2998
DescriptionInteger underflow in Mozilla Firefox 3.6.x before 3.6.23 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via JavaScript code containing a large RegExp expression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2312-1, DSA-2313-1, DSA-2317-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.2.0-2~deb7u1fixed
jessie38.8.0-1~deb8u1fixed
jessie (security)1:45.2.0-1~deb8u1fixed
stretch, sid1:45.2.0-4fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security), jessie38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-8high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-8highDSA-2312-1
icedovesource(unstable)3.1.15-1high
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze5highDSA-2317-1
iceweaselsource(unstable)7.0-1high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-10highDSA-2313-1
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-14highDSA-2313-1

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
Only affects firefox 3.6 code base, not 4.0 oder later
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems