CVE-2011-3650

NameCVE-2011-3650
DescriptionMozilla Firefox before 3.6.24 and 4.x through 7.0 and Thunderbird before 3.1.6 and 5.0 through 7.0 do not properly handle JavaScript files that contain many functions, which allows user-assisted remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via a crafted file that is accessed by debugging APIs, as demonstrated by Firebug.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2341-1, DSA-2342-1, DSA-2345-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.4.0-1~deb7u1fixed
jessie1:45.2.0-1~deb8u1fixed
jessie (security)1:45.4.0-1~deb8u1fixed
stretch1:45.4.0-1fixed
sid1:45.5.1-1fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-9high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-9highDSA-2342-1
icedovesource(unstable)3.1.16-1high
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze6highDSA-2345-1
iceweaselsource(unstable)8.0-1high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-11highDSA-2341-1
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-15highDSA-2341-1

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems