CVE-2011-3670

NameCVE-2011-3670
DescriptionMozilla Firefox before 3.6.26 and 4.x through 6.0, Thunderbird before 3.1.18 and 5.0 through 6.0, and SeaMonkey before 2.4 do not properly enforce the IPv6 literal address syntax, which allows remote attackers to obtain sensitive information by making XMLHttpRequest calls through a proxy and reading the error messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2400-1, DSA-2402-1, DSA-2406-1
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-10DSA-2402-1
iceapesource(unstable)2.0.14-10
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze7DSA-2406-1
icedovesource(unstable)7.0-1
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-12DSA-2400-1
iceweaselsource(unstable)7.0-1
xulrunnersourcelenny1.9.0.19-16DSA-2400-1
xulrunnersource(unstable)(unfixed)unimportant

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems