CVE-2011-4170

NameCVE-2011-4170
DescriptionCross-site scripting (XSS) vulnerability in the theme_adium_append_message function in empathy-theme-adium.c in the Adium theme in libempathy-gtk in Empathy 3.2.1 and earlier allows remote attackers to inject arbitrary web script or HTML via a crafted alias (aka nickname) in a /me event, a different vulnerability than CVE-2011-3635.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
empathy (PTS)stretch3.12.12-4fixed
buster3.25.90+really3.12.14-1fixed
bookworm, sid, bullseye3.25.90+really3.12.14-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
empathysourcelenny(not affected)
empathysource(unstable)3.2.1.1-1

Notes

[squeeze] - empathy <no-dsa> (Minor issue)
[lenny] - empathy <not-affected> (only affects webkit theming, not present in Lenny)

Search for package or bug name: Reporting problems