CVE-2011-4356

NameCVE-2011-4356
DescriptionCelery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
celery (PTS)jessie3.1.13-3fixed
stretch3.1.23-7fixed
buster4.2.1-3fixed
bullseye, sid4.2.1-5fixed
django-celery (PTS)jessie3.1.16-1fixed
stretch3.1.17-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
celerysource(unstable)2.4.6-1
django-celerysource(unstable)(not affected)

Notes

- django-celery <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems