CVE-2011-4357

NameCVE-2011-4357
DescriptionFormat string vulnerability in the p_cgi_error function in python/neo_cgi.c in the Python CGI Kit (neo_cgi) module for Clearsilver 0.10.5 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via format string specifiers that are not properly handled when creating CGI error messages using the cgi_error API function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2355-1
NVD severityhigh (attack range: remote)
Debian Bugs649322

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clearsilver (PTS)wheezy0.10.5-1.3fixed
jessie0.10.5-1.4fixed
stretch0.10.5-1.6fixed
buster, sid0.10.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clearsilversource(unstable)0.10.5-1.3high649322
clearsilversourcelenny0.10.4-1.3+lenny1highDSA-2355-1
clearsilversourcesqueeze0.10.5-1+squeeze1highDSA-2355-1

Search for package or bug name: Reporting problems