CVE-2011-4578

NameCVE-2011-4578
Descriptionevent.c in acpid (aka acpid2) before 2.0.11 does not have an appropriate umask setting during execution of event-handler scripts, which might allow local users to (1) perform write operations within directories created by a script, or (2) read files created by a script, via standard filesystem system calls.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2362-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
acpid (PTS)wheezy1:2.0.16-1+deb7u1fixed
jessie1:2.0.23-2fixed
buster, sid, stretch1:2.0.28-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
acpidsource(unstable)1:2.0.11-1medium
acpidsourcelenny1.0.8-1lenny4mediumDSA-2362-1
acpidsourcesqueeze1:2.0.7-1squeeze3mediumDSA-2362-1

Search for package or bug name: Reporting problems