CVE-2011-4599

NameCVE-2011-4599
DescriptionStack-based buffer overflow in the _canonicalize function in common/uloc.c in International Components for Unicode (ICU) before 49.1 allows remote attackers to execute arbitrary code via a crafted locale ID that is not properly handled during variant canonicalization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2397-1
NVD severityhigh (attack range: remote)
Debian Bugs654883

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)wheezy4.8.1.1-12+deb7u3fixed
wheezy (security)4.8.1.1-12+deb7u7fixed
jessie52.1-8+deb8u6fixed
jessie (security)52.1-8+deb8u5fixed
stretch57.1-6+deb9u1fixed
buster, sid57.1-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusource(unstable)4.8.1.1-3high654883
icusourcelenny3.8.1-3+lenny3highDSA-2397-1
icusourcesqueeze4.4.1-8highDSA-2397-1

Search for package or bug name: Reporting problems