CVE-2011-4969

NameCVE-2011-4969
DescriptionCross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs699482

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jquery (PTS)stretch3.1.1-2+deb9u1fixed
stretch (security)3.1.1-2+deb9u2fixed
buster3.3.1~dfsg-3+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jquerysource(unstable)1.6.4-1low699482

Notes

[squeeze] - jquery <no-dsa> (Minor issue)
http://blog.jquery.com/2011/09/01/jquery-1-6-3-released/
https://github.com/jquery/jquery/commit/db9e023e62c1ff5d8f21ed9868ab6878da2005e9

Search for package or bug name: Reporting problems