CVE-2012-0553

NameCVE-2012-0553
DescriptionBuffer overflow in yaSSL, as used in MySQL 5.1.x before 5.1.68 and 5.5.x before 5.5.28, has unspecified impact and attack vectors, a different vulnerability than CVE-2013-1492.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2780-1
NVD severityhigh (attack range: remote)
Debian Bugs712059
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyassl (PTS)sid2.9.4+dfsg-3fixed
mysql-5.1 (PTS)squeeze, squeeze (security)5.1.73-1fixed
squeeze (lts)5.1.73-1+deb6u1fixed
mysql-5.5 (PTS)wheezy5.5.40-0+wheezy1fixed
wheezy (security)5.5.43-0+deb7u1fixed
stretch, sid, jessie5.5.42-1fixed
jessie (security)5.5.43-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyasslsource(unstable)(not affected)
mysql-5.1source(unstable)(unfixed)high712059
mysql-5.1sourcesqueeze5.1.72-2highDSA-2780-1
mysql-5.5source(unstable)5.5.28+dfsg-1high

Notes

- cyassl <not-affected> (Fixed before initial upload to archive)
https://blogs.oracle.com/sunsecurity/entry/cve_2012_0553_buffer_overflow

Search for package or bug name: Reporting problems