CVE-2012-0786

NameCVE-2012-0786
DescriptionThe transform_save function in transform.c in Augeas before 1.0.0 allows local users to overwrite arbitrary files and obtain sensitive information via a symlink attack on a .augnew file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-28-1
NVD severitylow (attack range: local)
Debian Bugs731132

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
augeas (PTS)wheezy0.10.0-1vulnerable
wheezy (security)0.10.0-1+deb7u1vulnerable
jessie (security), jessie1.2.0-0.2+deb8u2fixed
stretch (security), stretch1.8.0-1+deb9u1fixed
buster, sid1.9.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
augeassource(unstable)1.0.0-1low731132
augeassourcesqueeze0.7.2-1+deb6u1lowDLA-28-1

Notes

[wheezy] - augeas <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems