CVE-2012-0790

NameCVE-2012-0790
DescriptionCross-site scripting (XSS) vulnerability in smokeping_cgi in Smokeping 2.4.2, 2.6.6, and other versions before 2.6.7 allows remote attackers to inject arbitrary web script or HTML via the displaymode parameter.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
ReferencesDSA-2651-1
NVD severitymedium (attack range: remote)
Debian Bugs659899
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smokeping (PTS)squeeze, squeeze (security)2.3.6-5+squeeze1fixed
squeeze (lts)2.3.6-5+squeeze2fixed
wheezy2.6.8-2fixed
wheezy (security)2.6.8-2+deb7u1fixed
jessie (security), jessie2.6.9-1+deb8u1fixed
stretch, sid2.6.11-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smokepingsource(unstable)2.6.8-2medium659899
smokepingsourcesqueeze2.3.6-5+squeeze1mediumDSA-2651-1

Search for package or bug name: Reporting problems