DescriptionInteger overflow in the vclmi.dll module in (OOo) 3.3, 3.4 Beta, and possibly earlier, and LibreOffice before 3.5.3, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted embedded image object, as demonstrated by a JPEG image in a .DOC file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2473-1, DSA-2487-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)wheezy1:3.5.4+dfsg2-0+deb7u2fixed
wheezy (security)1:3.5.4+dfsg2-0+deb7u4fixed
jessie (security), jessie1:4.3.3-2+deb8u1fixed
stretch, sid1:4.4.4-1fixed (PTS)squeeze, squeeze (security)1:3.2.1-11+squeeze8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Since 3.3.0 is a transitional source package to migrate to libreoffice

Search for package or bug name: Reporting problems