CVE-2012-1181

NameCVE-2012-1181
Descriptionfcgid_spawn_ctl.c in the mod_fcgid module 2.3.6 for the Apache HTTP Server does not recognize the FcgidMaxProcessesPerClass directive for a virtual host, which makes it easier for remote attackers to cause a denial of service (memory consumption) via a series of HTTP requests that triggers a process count higher than the intended limit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2436-1
NVD severitymedium (attack range: remote)
Debian Bugs615814

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-fcgid (PTS)wheezy, wheezy (security)1:2.3.6-1.2+deb7u1fixed
buster, sid, jessie, stretch1:2.3.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-fcgidsource(unstable)1:2.3.6-1.1medium615814
libapache2-mod-fcgidsourcesqueeze1:2.3.6-1+squeeze1mediumDSA-2436-1

Search for package or bug name: Reporting problems