DescriptionUse-after-free vulnerability in icclib before 2.13, as used by Argyll CMS before 1.4 and possibly other programs, allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted ICC profile file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
argyll (PTS)buster2.0.1+repack-1fixed
sid, trixie3.1.0+repack-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[squeeze] - argyll <no-dsa> (Only standalone binary in squeeze, minor impact)
Starting with 1.4.0 argyll includes icclib 2.13, but it's hard to identify the
isolated security fix

Search for package or bug name: Reporting problems