CVE-2012-1836

NameCVE-2012-1836
DescriptionHeap-based buffer overflow in dns.cpp in InspIRCd 2.0.5 might allow remote attackers to execute arbitrary code via a crafted DNS query that uses compression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2448-1
NVD severityhigh (attack range: remote)
Debian Bugs667914

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)wheezy, wheezy (security)2.0.5-1+deb7u2fixed
jessie (security), jessie2.0.17-1+deb8u2fixed
stretch2.0.23-2fixed
buster, sid2.0.24-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inspircdsource(unstable)2.0.5-0.1high667914
inspircdsourcesqueeze1.1.22+dfsg-4+squeeze1highDSA-2448-1
inspircdsourcewheezy1.1.22+dfsg-4+wheezy1highDSA-2448-1

Search for package or bug name: Reporting problems