CVE-2012-2085

NameCVE-2012-2085
DescriptionThe exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2453-1, DSA-2453-2
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs668038
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gajim (PTS)squeeze (security), squeeze0.13.4-3+squeeze3fixed
wheezy0.15.1-4.1fixed
jessie, sid0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gajimsource(unstable)0.15-1medium668038
gajimsourcesqueeze0.13.4-3+squeeze3mediumDSA-2453-2

Search for package or bug name: Reporting problems