CVE-2012-2091

NameCVE-2012-2091
DescriptionMultiple buffer overflows in FlightGear 2.6 and earlier and SimGear 2.6 and earlier allow user-assisted remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a (1) long string in a rotor tag of an aircraft xml model to the Rotor::getValueforFGSet function in src/FDM/YASim/Rotor.cpp or (2) a crafted UDP packet to the SGSocketUDP::read function in simgear/simgear/simgear/io/sg_socket_udp.cxx.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs669024, 669025

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flightgear (PTS)jessie3.0.0-5+deb8u3fixed
jessie (security)3.0.0-5+deb8u1fixed
stretch1:2016.4.4+dfsg-3+deb9u1fixed
buster, sid1:2018.1.1+dfsg-3fixed
simgear (PTS)jessie3.0.0-6fixed
stretch1:2016.4.4+dfsg-2fixed
buster, sid1:2018.1.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flightgearsource(unstable)2.6.0-1.1unimportant669025
simgearsource(unstable)2.10.0-3unimportant669024

Notes

Negligable security impact, very obscure attack vector

Search for package or bug name: Reporting problems