CVE-2012-2104

NameCVE-2012-2104
Descriptioncgi-bin/munin-cgi-graph in Munin 2.x writes data to a log file without sanitizing non-printable characters, which might allow user-assisted remote attackers to inject terminal emulator escape sequences and execute arbitrary commands or delete arbitrary files via a crafted HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs668666

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
munin (PTS)buster2.0.49-1fixed
bullseye2.0.67-3fixed
bookworm, sid2.0.69-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muninsourcelenny(not affected)
muninsourcesqueeze(not affected)
muninsource(unstable)2.0~rc6-1668666

Notes

[squeeze] - munin <not-affected> (Vulnerable code not present)
[lenny] - munin <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems