CVE-2012-2369

NameCVE-2012-2369
DescriptionFormat string vulnerability in the log_message_cb function in otr-plugin.c in the Off-the-Record Messaging (OTR) pidgin-otr plugin before 3.2.1 for Pidgin might allow remote attackers to execute arbitrary code via format string specifiers in data that generates a log message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2476-1
NVD severityhigh (attack range: remote)
Debian Bugs673154
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin-otr (PTS)squeeze, squeeze (security)3.2.0-5+squeeze1fixed
wheezy3.2.1-3+deb7u1fixed
stretch, sid, jessie4.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pidgin-otrsource(unstable)3.2.1-1medium673154
pidgin-otrsourcesqueeze3.2.0-5+squeeze1highDSA-2476-1

Notes

libotr not affected

Search for package or bug name: Reporting problems