CVE-2012-2417

NameCVE-2012-2417
DescriptionPyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2502-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-crypto (PTS)squeeze (security), squeeze2.1.0-2+squeeze2fixed
wheezy, wheezy (security)2.6-4+deb7u3fixed
jessie, sid2.6.1-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-cryptosource(unstable)2.6-1medium
python-cryptosourcesqueeze2.1.0-2+squeeze1mediumDSA-2502-1

Notes

https://bugs.launchpad.net/pycrypto/+bug/985164

Search for package or bug name: Reporting problems