CVE-2012-2658

NameCVE-2012-2658
Description** DISPUTED ** Buffer overflow in the SQLDriverConnect function in unixODBC 2.3.1 allows local users to cause a denial of service (crash) via a long string in the DRIVER option. NOTE: this issue might not be a vulnerability, since the ability to set this option typically implies that the attacker already has legitimate access to cause a DoS or execute code, and therefore the issue would not cross privilege boundaries. There may be limited attack scenarios if isql command-line options are exposed to an attacker, although it seems likely that other, more serious issues would also be exposed, and this issue might not cross privilege boundaries in that context.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs675058

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unixodbc (PTS)wheezy2.2.14p2-5vulnerable
jessie2.3.1-3vulnerable
buster, sid, stretch2.3.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unixodbcsource(unstable)(unfixed)unimportant675058

Notes

Only triggerable by trusted input, not a security issue

Search for package or bug name: Reporting problems