CVE-2012-2665

NameCVE-2012-2665
DescriptionMultiple heap-based buffer overflows in the XML manifest encryption tag parsing functionality in OpenOffice.org and LibreOffice before 3.5.5 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Open Document Text (.odt) file with (1) a child tag within an incorrect parent tag, (2) duplicate tags, or (3) a Base64 ChecksumAttribute whose length is not evenly divisible by four.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2520-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)wheezy1:3.5.4+dfsg2-0+deb7u2fixed
wheezy (security)1:3.5.4+dfsg2-0+deb7u4fixed
jessie (security), jessie1:4.3.3-2+deb8u1fixed
stretch, sid1:4.4.4-1fixed
openoffice.org (PTS)squeeze, squeeze (security)1:3.2.1-11+squeeze8fixed
wheezy1:3.4.0~ooo340m1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:3.5.4-7high
openoffice.orgsource(unstable)1:3.3.0-1high
openoffice.orgsourcesqueeze1:3.2.1-11+squeeze7highDSA-2520-1

Notes

Since 3.3.0 openoffice.org is a transitional source package

Search for package or bug name: Reporting problems