CVE-2012-3158

NameCVE-2012-3158
DescriptionUnspecified vulnerability in the MySQL Server component in Oracle MySQL 5.1.64 and earlier, and 5.5.26 and earlier, allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors related to Protocol.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2581-1
NVD severityhigh (attack range: remote)
Debian Bugs690778
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-5.1 (PTS)squeeze, squeeze (security)5.1.73-1fixed
squeeze (lts)5.1.73-1+deb6u1fixed
mysql-5.5 (PTS)wheezy5.5.40-0+wheezy1fixed
wheezy (security)5.5.43-0+deb7u1fixed
jessie (security)5.5.43-0+deb8u1fixed
stretch, jessie, sid5.5.42-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-5.1source(unstable)(unfixed)high
mysql-5.1sourcesqueeze5.1.66-0+squeeze1highDSA-2581-1
mysql-5.5source(unstable)5.5.28+dfsg-1high690778

Search for package or bug name: Reporting problems