CVE-2012-4433

NameCVE-2012-4433
DescriptionMultiple integer overflows in operations/external/ppm-load.c in GEGL (Generic Graphics Library) 0.2.0 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a large (1) width or (2) height value in a Portable Pixel Map (ppm) image, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs692435

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gegl (PTS)jessie0.2.0-7fixed
stretch0.3.8-4fixed
buster0.4.12-2fixed
bullseye, sid0.4.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
geglsource(unstable)0.2.0-2+nmu1692435
geglsourcesqueeze(not affected)

Notes

[squeeze] - gegl <not-affected> (PPM code not yet present)
http://seclists.org/oss-sec/2012/q4/215

Search for package or bug name: Reporting problems