CVE-2012-4523

NameCVE-2012-4523
Descriptionradsecproxy before 1.6.1 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2573-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
radsecproxy (PTS)squeeze, squeeze (security)1.4-1+squeeze1fixed
wheezy1.6.2-1fixed
sid, stretch, jessie1.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
radsecproxysource(unstable)1.6.2-1medium
radsecproxysourcesqueeze1.4-1+squeeze1mediumDSA-2573-1

Search for package or bug name: Reporting problems