CVE-2012-5529

NameCVE-2012-5529
DescriptionTraceManager in Firebird 2.5.0 and 2.5.1, when trace is enabled, allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) by preparing an empty dynamic SQL query.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2648-1
NVD severitylow (attack range: remote)
Debian Bugs693210
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firebird2.1 (PTS)squeeze (security), squeeze2.1.3.18185-0.ds1-11+squeeze1fixed
squeeze (lts)2.1.3.18185-0.ds1-11+squeeze2fixed
firebird2.5 (PTS)squeeze (security), squeeze2.5.0.26054~ReleaseCandidate3.ds2-1+squeeze1fixed
squeeze (lts)2.5.0.26054~ReleaseCandidate3.ds2-1+squeeze2fixed
wheezy, wheezy (security)2.5.2.26540.ds4-1~deb7u2fixed
jessie, sid2.5.3.26778.ds4-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firebird2.1source(unstable)(not affected)
firebird2.5source(unstable)2.5.2~svn+54698.ds4-2low693210
firebird2.5sourcesqueeze2.5.0.26054~ReleaseCandidate3.ds2-1+squeeze1lowDSA-2648-1

Notes

- firebird2.1 <not-affected> (Only affects 2.5.x)

Search for package or bug name: Reporting problems