CVE-2012-5614

NameCVE-2012-5614
DescriptionOracle MySQL 5.1.67 and earlier and 5.5.29 and earlier, and MariaDB 5.5.28a and possibly other versions, allows remote authenticated users to cause a denial of service (mysqld crash) via a SELECT command with an UpdateXML command containing XML with a large number of unique, nested elements.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-5.5 (PTS)jessie5.5.60-0+deb8u1fixed
jessie (security)5.5.62-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-5.5source(unstable)(not affected)
mysql-5.1source(unstable)(unfixed)low
mysql-5.1sourcesqueeze5.1.73-1medium
mysql-5.5source(unstable)(not affected)

Notes

- mariadb-5.5 <not-affected> (Fixed before initial upload to archive)
- mysql-5.5 <not-affected> (The affected versions were only in experimental)
https://mariadb.atlassian.net/browse/MDEV-3910
http://seclists.org/fulldisclosure/2012/Dec/7
http://www.openwall.com/lists/oss-security/2013/02/28/10

Search for package or bug name: Reporting problems