CVE-2012-6696

NameCVE-2012-6696
Descriptioninspircd in Debian before 2.0.7 does not properly handle unsigned integers. NOTE: This vulnerability exists because of an incomplete fix to CVE-2012-1836.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-276-1, DSA-3226-1
NVD severityhigh
Debian Bugs780880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)jessie (security), jessie2.0.17-1+deb8u2fixed
stretch2.0.23-2fixed
buster2.0.27-1fixed
bullseye, sid3.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inspircdsource(unstable)2.0.16-1780880
inspircdsourcesqueeze1.1.22+dfsg-4+squeeze2DLA-276-1
inspircdsourcewheezy2.0.5-1+deb7u1DSA-3226-1

Notes

Correct fix: https://github.com/inspircd/inspircd/commit/ed28c1ba666b39581adb860bf51cdde43c84cc89
http://www.openwall.com/lists/oss-security/2015/03/29/5

Search for package or bug name: Reporting problems