CVE-2012-6697

NameCVE-2012-6697
DescriptionInspIRCd before 2.0.7 allows remote attackers to cause a denial of service (infinite loop).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-276-1, DSA-3226-1
NVD severitymedium
Debian Bugs780880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
inspircd (PTS)stretch2.0.23-2fixed
buster2.0.27-1fixed
bullseye, sid3.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
inspircdsource(unstable)2.0.16-1780880
inspircdsourcesqueeze1.1.22+dfsg-4+squeeze2DLA-276-1
inspircdsourcewheezy2.0.5-1+deb7u1DSA-3226-1

Notes

https://github.com/inspircd/inspircd/commit/58c893e834ff20495d007709220881a3ff13f423
http://www.openwall.com/lists/oss-security/2015/03/29/5

Search for package or bug name: Reporting problems