CVE-2013-0191

NameCVE-2013-0191
Descriptionlibpam-pgsql (aka pam_pgsql) 0.7 does not properly handle a NULL value returned by the password search query, which allows remote attackers to bypass authentication via a crafted password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs698241

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pam-pgsql (PTS)stretch, sid0.7.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pam-pgsqlsourcesqueeze0.7.1-4+squeeze2
pam-pgsqlsource(unstable)0.7.3.1-4698241

Notes

patch: https://sourceforge.net/u/lvella/pam-pgsql/ci/9361f5970e5dd90a747319995b67c2f73b91448c/
bugreport: https://sourceforge.net/p/pam-pgsql/bugs/13/

Search for package or bug name: Reporting problems