CVE-2013-0269

NameCVE-2013-0269
DescriptionThe JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-215-1, DLA-263-1
NVD severityhigh (attack range: remote)
Debian Bugs700436, 700471

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-json (PTS)wheezy1.7.3-3fixed
jessie1.8.1-1fixed
stretch2.0.1+dfsg-3fixed
buster, sid2.1.0+dfsg-1fixed
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5fixed
wheezy (security)1.9.3.194-8.1+deb7u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libjson-rubysource(unstable)(unfixed)high
libjson-rubysourcesqueeze1.1.9-1+deb6u1highDLA-215-1
ruby-jsonsource(unstable)1.7.3-3high700436
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)1.9.3.194-7high700471
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u5highDLA-263-1

Notes

- ruby1.8 <not-affected> (json ext not present in 1.8)

Search for package or bug name: Reporting problems