CVE-2013-1861

NameCVE-2013-1861
DescriptionMariaDB 5.5.x before 5.5.30, 5.3.x before 5.3.13, 5.2.x before 5.2.15, and 5.1.x before 5.1.68, and Oracle MySQL 5.1.69 and earlier, 5.5.31 and earlier, and 5.6.11 and earlier allows remote attackers to cause a denial of service (crash) via a crafted geometry feature that specifies a large number of points, which is not properly handled when processing the binary representation of this feature, related to a numeric calculation error.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2780-1, DSA-2818-1
NVD severitymedium (attack range: remote)
Debian Bugs706715
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.0 (PTS)jessie10.0.16-1fixed
stretch10.0.19-1fixed
sid10.0.20-1fixed
mysql-5.1 (PTS)squeeze, squeeze (security)5.1.73-1fixed
squeeze (lts)5.1.73-1+deb6u1fixed
mysql-5.5 (PTS)wheezy5.5.40-0+wheezy1fixed
wheezy (security)5.5.43-0+deb7u1fixed
stretch, sid, jessie (security), jessie5.5.43-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.0source(unstable)(not affected)
mariadb-5.5source(unstable)(not affected)
mysql-5.1source(unstable)(unfixed)low706715
mysql-5.1sourcesqueeze5.1.72-2mediumDSA-2780-1
mysql-5.5source(unstable)5.5.33+dfsg-1low706715
mysql-5.5sourcewheezy5.5.33+dfsg-0+wheezy1mediumDSA-2818-1

Notes

- mariadb-5.5 <not-affected> (Fixed before initial upload to archive)
- mariadb-10.0 <not-affected> (Fixed before initial upload)
https://mariadb.atlassian.net/browse/MDEV-4252

Search for package or bug name: Reporting problems