CVE-2013-1900

NameCVE-2013-1900
DescriptionPostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x before 9.0.13, and 8.4.x before 8.4.17, when using OpenSSL, generates insufficiently random numbers, which might allow remote authenticated users to have an unspecified impact via vectors related to the "contrib/pgcrypto functions."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2657-1, DSA-2658-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)squeeze8.4.21-0squeeze1fixed
squeeze (security)8.4.20-0squeeze1fixed
squeeze (lts)8.4.22lts2-0+deb6u2fixed
wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.14-0+deb7u1fixed
wheezy (security)9.1.16-0+deb7u1fixed
jessie9.1.15-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)8.4.17-1high
postgresql-8.4sourcesqueeze8.4.17-0squeeze1highDSA-2657-1
postgresql-9.1source(unstable)9.1.9-1high
postgresql-9.1sourcewheezy9.1.9-0wheezy1highDSA-2658-1

Search for package or bug name: Reporting problems