Information on source package postgresql-9.1

Available versions

ReleaseVersion
jessie9.1.22-0+deb8u1
jessie (security)9.1.16-0+deb8u1

Open issues

BugjessieDescription
CVE-2018-10915vulnerable (no DSA)A vulnerability was found in libpq, the default PostgreSQL client ...

Resolved issues

BugDescription
CVE-2018-1115postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack ...
CVE-2018-10925It was discovered that PostgreSQL versions before 10.5, 9.6.10, ...
CVE-2018-1058A flaw was found in the way Postgresql allowed a user to modify the ...
CVE-2018-1053In postgresql 9.3.x before 9.3.21, 9.4.x before 9.4.16, 9.5.x before ...
CVE-2018-1052Memory disclosure vulnerability in table partitioning was found in ...
CVE-2017-7548PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to ...
CVE-2017-7547PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are ...
CVE-2017-7546PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are ...
CVE-2017-7486PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in ...
CVE-2017-7485In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before ...
CVE-2017-7484It was found that some selectivity estimation functions in PostgreSQL ...
CVE-2017-15099INSERT ... ON CONFLICT DO UPDATE commands in PostgreSQL 10.x before ...
CVE-2017-15098Invalid json_populate_recordset or jsonb_populate_recordset function ...
CVE-2017-12172PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, 9.5.x before 9.5.10, ...
CVE-2016-5424PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, ...
CVE-2016-5423PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, ...
CVE-2016-3065The (1) brin_page_type and (2) brin_metapage_info functions in the ...
CVE-2016-2193PostgreSQL before 9.5.x before 9.5.2 does not properly maintain ...
CVE-2016-0773PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, ...
CVE-2016-0766PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, ...
CVE-2015-5289Multiple stack-based buffer overflows in json parsing in PostgreSQL ...
CVE-2015-5288The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, ...
CVE-2015-3167
CVE-2015-3166
CVE-2015-3165Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before ...
CVE-2015-0244
CVE-2015-0243
CVE-2015-0242
CVE-2015-0241
CVE-2014-8161
CVE-2014-2669Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL ...
CVE-2014-0067The "make check" command for the test suites in PostgreSQL 9.3.3 and ...
CVE-2014-0066The chkpass extension in PostgreSQL before 8.4.20, 9.0.x before ...
CVE-2014-0065Multiple buffer overflows in PostgreSQL before 8.4.20, 9.0.x before ...
CVE-2014-0064Multiple integer overflows in the path_in and other unspecified ...
CVE-2014-0063Multiple stack-based buffer overflows in PostgreSQL before 8.4.20, ...
CVE-2014-0062Race condition in the (1) CREATE INDEX and (2) unspecified ALTER TABLE ...
CVE-2014-0061The validator functions for the procedural languages (PLs) in ...
CVE-2014-0060PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, ...
CVE-2013-1903PostgreSQL, possibly 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x ...
CVE-2013-1902PostgreSQL, 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x before ...
CVE-2013-1901PostgreSQL 9.2.x before 9.2.4 and 9.1.x before 9.1.9 does not properly ...
CVE-2013-1900PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x before ...
CVE-2013-1899Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, ...
CVE-2013-0255PostgreSQL 9.2.x before 9.2.3, 9.1.x before 9.1.8, 9.0.x before ...
CVE-2012-3489The xml_parse function in the libxml2 support in the core server ...
CVE-2012-3488The libxslt support in contrib/xml2 in PostgreSQL 8.3 before 8.3.20, ...
CVE-2012-2655PostgreSQL 8.3.x before 8.3.19, 8.4.x before 8.4.12, 9.0.x before ...
CVE-2012-2143The crypt_des (aka DES-based crypt) function in FreeBSD before ...
CVE-2012-0868CRLF injection vulnerability in pg_dump in PostgreSQL 8.3.x before ...
CVE-2012-0867PostgreSQL 8.4.x before 8.4.11, 9.0.x before 9.0.7, and 9.1.x before ...
CVE-2012-0866CREATE TRIGGER in PostgreSQL 8.3.x before 8.3.18, 8.4.x before 8.4.11, ...
CVE-2011-2483crypt_blowfish before 1.1, as used in PHP before 5.3.7 on certain ...

Security announcements

DSA / DLADescription
DLA-1271-1postgresql-9.1 - security update
DLA-1051-1postgresql-9.1 - security update
DLA-709-1postgresql-9.1 - bugfix update
DLA-592-1postgresql-9.1 - security update
DLA-491-1postgresql-9.1 - bugfix update
DSA-3475-1postgresql-9.1 - security update
DSA-3269-2postgresql-9.1 - regression update
DSA-3269-1postgresql-9.1 - security update
DSA-3269-1postgresql-9.1 - security update
DSA-3155-1postgresql-9.1 - security update
DSA-2865-1postgresql-9.1 - several
DSA-2658-1postgresql-9.1 - several

Search for package or bug name: Reporting problems