CVE-2013-1991

NameCVE-2013-1991
DescriptionMultiple integer overflows in X.org libXxf86dga 1.1.3 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XDGAQueryModes and (2) XDGASetMode functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2690-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxxf86dga (PTS)squeeze, squeeze (security)2:1.1.1-2+squeeze1fixed
wheezy, wheezy (security)2:1.1.3-2+deb7u1fixed
stretch, sid, jessie2:1.1.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxxf86dgasource(unstable)2:1.1.3-2+deb7u1medium
libxxf86dgasourcesqueeze2:1.1.1-2+squeeze1mediumDSA-2690-1
libxxf86dgasourcewheezy2:1.1.3-2+deb7u1mediumDSA-2690-1

Search for package or bug name: Reporting problems