CVE-2013-1995

NameCVE-2013-1995
DescriptionX.org libXi 1.7.1 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to an unexpected sign extension in the XListInputDevices function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2683-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxi (PTS)squeeze (security), squeeze2:1.3-8fixed
wheezy, wheezy (security)2:1.6.1-1+deb7u1fixed
jessie, sid2:1.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxisource(unstable)2:1.6.1-1+deb7u1medium
libxisourcesqueeze2:1.3-8mediumDSA-2683-1
libxisourcewheezy2:1.6.1-1+deb7u1mediumDSA-2683-1

Search for package or bug name: Reporting problems