CVE-2013-1998

NameCVE-2013-1998
DescriptionMultiple buffer overflows in X.org libXi 1.7.1 and earlier allow X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the (1) XGetDeviceButtonMapping, (2) XIPassiveGrabDevice, and (3) XQueryDeviceState functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2683-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxi (PTS)squeeze, squeeze (security)2:1.3-8fixed
squeeze (lts)2:1.3-8+build1fixed
wheezy (security), wheezy2:1.6.1-1+deb7u1fixed
stretch, sid, jessie2:1.7.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxisource(unstable)2:1.6.1-1+deb7u1medium
libxisourcesqueeze2:1.3-8mediumDSA-2683-1
libxisourcewheezy2:1.6.1-1+deb7u1mediumDSA-2683-1

Search for package or bug name: Reporting problems