CVE-2013-2001

NameCVE-2013-2001
DescriptionBuffer overflow in X.org libXxf86vm 1.1.2 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XF86VidModeGetGammaRamp function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2692-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxxf86vm (PTS)squeeze, squeeze (security)1:1.1.0-2+squeeze1fixed
wheezy, wheezy (security)1:1.1.2-1+deb7u1fixed
jessie1:1.1.3-1fixed
stretch, sid1:1.1.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxxf86vmsource(unstable)1:1.1.2-1+deb7u1medium
libxxf86vmsourcesqueeze1:1.1.0-2+squeeze1mediumDSA-2692-1
libxxf86vmsourcewheezy1:1.1.2-1+deb7u1mediumDSA-2692-1

Search for package or bug name: Reporting problems