CVE-2013-2178

NameCVE-2013-2178
DescriptionThe apache-auth.conf, apache-nohome.conf, apache-noscript.conf, and apache-overflows.conf files in Fail2ban before 0.8.10 do not properly validate log messages, which allows remote attackers to block arbitrary IP addresses via certain messages in a request.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2708-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fail2ban (PTS)squeeze (security), squeeze0.8.4-3+squeeze2fixed
squeeze (lts)0.8.4-3+squeeze3fixed
wheezy, wheezy (security)0.8.6-3wheezy3fixed
jessie0.8.13-1fixed
sid0.9.1-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fail2bansource(unstable)0.8.10-1medium
fail2bansourcesqueeze0.8.4-3+squeeze2mediumDSA-2708-1
fail2bansourcewheezy0.8.6-3wheezy2mediumDSA-2708-1

Search for package or bug name: Reporting problems