CVE-2013-4440

NameCVE-2013-4440
DescriptionPassword Generator (aka Pwgen) before 2.07 generates weak non-tty passwords, which makes it easier for context-dependent attackers to guess the password via a brute-force attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs725507

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pwgen (PTS)wheezy2.06-1vulnerable
jessie2.07-1fixed
stretch2.07-1.1fixed
buster, sid2.08-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pwgensource(unstable)2.07-1unimportant725507

Notes

Documented shortcoming

Search for package or bug name: Reporting problems