CVE-2013-4492

NameCVE-2013-4492
DescriptionCross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6 for Ruby allows remote attackers to inject arbitrary web script or HTML via a crafted I18n::MissingTranslationData.new call.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2830-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libi18n-ruby (PTS)squeeze0.4.1-1fixed
ruby-i18n (PTS)wheezy, wheezy (security)0.6.0-3+deb7u1fixed
jessie0.6.9-2fixed
sid0.6.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libi18n-rubysource(unstable)(unfixed)medium
libi18n-rubysourcesqueeze(not affected)
ruby-i18nsource(unstable)0.6.9-1medium
ruby-i18nsourcewheezy0.6.0-3+deb7u1mediumDSA-2830-1

Notes

[squeeze] - libi18n-ruby <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems