CVE-2013-4852

NameCVE-2013-4852
DescriptionInteger overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2736-1
NVD severitymedium (attack range: remote)
Debian Bugs718779, 718800
Debian/oldoldstablepackage filezilla is vulnerable.
Debian/oldstablepackage filezilla is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
filezilla (PTS)squeeze3.3.3-1vulnerable
wheezy3.5.3-2vulnerable
stretch, jessie3.9.0.5-1fixed
sid3.12.0.2-1fixed
putty (PTS)squeeze, squeeze (security)0.60+2010-02-20-1+squeeze2fixed
squeeze (lts)0.60+2010-02-20-1+squeeze3fixed
wheezy0.62-9+deb7u1fixed
wheezy (security)0.62-9+deb7u2fixed
jessie0.63-10fixed
stretch, sid0.65-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filezillasource(unstable)3.7.3-1low718800
puttysource(unstable)0.63-1medium718779
puttysourcesqueeze0.60+2010-02-20-1+squeeze2mediumDSA-2736-1
puttysourcewheezy0.62-9+deb7u1mediumDSA-2736-1

Notes

[squeeze] - filezilla <no-dsa> (Minor issue)
[wheezy] - filezilla <no-dsa> (Minor issue)
http://www.securityfocus.com/archive/1/527763/30/0
http://svn.tartarus.org/sgt?view=revision&sortby=date&revision=9896

Search for package or bug name: Reporting problems