CVE-2013-6370

NameCVE-2013-6370
DescriptionBuffer overflow in the printbuf APIs in json-c before 0.12 allows remote attackers to cause a denial of service via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs744008

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
json-c (PTS)stretch0.12.1-1.1fixed
stretch (security)0.12.1-1.1+deb9u1fixed
buster, buster (security)0.12.1+ds-2+deb10u1fixed
bullseye0.15-2fixed
bookworm, sid0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
json-csource(unstable)0.11-4744008

Notes

[wheezy] - json-c <no-dsa> (Minor issue)
[squeeze] - json-c <no-dsa> (Minor issue)
https://github.com/json-c/json-c/commit/64e36901a0614bf64a19bc3396469c66dcd0b015

Search for package or bug name: Reporting problems