CVE-2013-6393

NameCVE-2013-6393
DescriptionThe yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2850-1, DSA-2870-1
NVD severitymedium (attack range: remote)
Debian Bugs737076
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libyaml (PTS)squeeze (security), squeeze0.1.3-1+deb6u4fixed
squeeze (lts)0.1.3-1+deb6u5fixed
wheezy, wheezy (security)0.1.4-2+deb7u5fixed
jessie, sid0.1.6-3fixed
libyaml-libyaml-perl (PTS)squeeze (security), squeeze0.33-1+squeeze3fixed
squeeze (lts)0.33-1+squeeze4fixed
wheezy, wheezy (security)0.38-3+deb7u3fixed
jessie, sid0.41-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libyamlsource(unstable)0.1.4-3medium737076
libyamlsourcesqueeze0.1.3-1+deb6u2mediumDSA-2850-1
libyamlsourcewheezy0.1.4-2+deb7u2mediumDSA-2850-1
libyaml-libyaml-perlsource(unstable)0.41-4medium
libyaml-libyaml-perlsourcesqueeze0.33-1+squeeze2mediumDSA-2870-1
libyaml-libyaml-perlsourcewheezy0.38-3+deb7u1mediumDSA-2870-1

Search for package or bug name: Reporting problems