CVE-2013-6459

NameCVE-2013-6459
DescriptionCross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs733209

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-will-paginate (PTS)wheezy3.0.3-1vulnerable
jessie3.0.5-1fixed
stretch3.1.5-1fixed
buster, sid3.1.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwill-paginate-rubysource(unstable)(unfixed)medium
ruby-will-paginatesource(unstable)3.0.5-1low733209

Notes

[wheezy] - ruby-will-paginate <no-dsa> (Minor issue)
[squeeze] - libwill-paginate-ruby <no-dsa> (Minor issue)
https://github.com/mislav/will_paginate/releases/tag/v3.0.5

Search for package or bug name: Reporting problems