DescriptionMultiple integer overflows in (1) OPVPOutputDev.cxx and (2) oprs/OPVPSplash.cxx in the pdftoopvp filter in CUPS and cups-filters before 1.0.47 allow remote attackers to execute arbitrary code via a crafted PDF file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
ReferencesDSA-2875-1, DSA-2876-1
NVD severitymedium (attack range: remote)
Debian Bugs741318, 741333
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)squeeze1.4.4-7+squeeze5fixed
squeeze (security)1.4.4-7+squeeze4fixed
squeeze (lts)1.4.4-7+squeeze10fixed
wheezy (security), wheezy1.5.3-5+deb7u6fixed
jessie (security), jessie1.7.5-11+deb8u1fixed
stretch, sid2.1.0-6fixed
cups-filters (PTS)wheezy (security), wheezy1.0.18-2.1+deb7u2fixed
jessie (security), jessie1.0.61-5+deb8u1fixed
stretch, sid1.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


cups moved filters to separate package in 1.5.0-16
in oldstable present in debian/local/filters/pdf-filters/pdftoopvp

Search for package or bug name: Reporting problems