Information on source package cups-filters

Available versions

ReleaseVersion
stretch1.11.6-3+deb9u1
buster1.21.6-5
bullseye1.28.5-1
sid1.28.5-1

Resolved issues

BugDescription
TEMP-0000000-ACBC4Cbuffer overflows in init_cups
CVE-2015-8560Incomplete blacklist vulnerability in util.c in foomatic-rip in cups-f ...
CVE-2015-8327Incomplete blacklist vulnerability in util.c in foomatic-rip in cups-f ...
CVE-2015-3279Integer overflow in filter/texttopdf.c in texttopdf in cups-filters be ...
CVE-2015-3258Heap-based buffer overflow in the WriteProlog function in filter/textt ...
CVE-2015-2265The remove_bad_chars function in utils/cups-browsed.c in cups-filters ...
CVE-2014-4338cups-browsed in cups-filters before 1.0.53 allows remote attackers to ...
CVE-2014-4337The process_browse_data function in utils/cups-browsed.c in cups-brows ...
CVE-2014-4336The generate_local_queue function in utils/cups-browsed.c in cups-brow ...
CVE-2014-2707cups-browsed in cups-filters 1.0.41 before 1.0.51 allows remote IPP pr ...
CVE-2013-6476The OPVPWrapper::loadDriver function in oprs/OPVPWrapper.cxx in the pd ...
CVE-2013-6475Multiple integer overflows in (1) OPVPOutputDev.cxx and (2) oprs/OPVPS ...
CVE-2013-6474Heap-based buffer overflow in the pdftoopvp filter in CUPS and cups-fi ...
CVE-2013-6473Multiple heap-based buffer overflows in the urftopdf filter in cups-fi ...
CVE-2010-5325Heap-based buffer overflow in the unhtmlify function in foomatic-rip i ...

Security announcements

DSA / DLADescription
DLA-1792-2cups-filters - regression update
DSA-4442-2cups-filters - regression update
DSA-3419-1cups-filters - security update
DSA-3411-1cups-filters - security update
DSA-3303-1cups-filters - security update
DSA-2875-1cups-filters - security update

Search for package or bug name: Reporting problems