CVE-2013-6487

NameCVE-2013-6487
DescriptionInteger overflow in libpurple/protocols/gg/lib/http.c in the Gadu-Gadu (gg) parser in Pidgin before 2.10.8 allows remote attackers to have an unspecified impact via a large Content-Length value, which triggers a buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2852-1, DSA-2859-1
NVD severityhigh (attack range: remote)
Debian/oldstablepackage pidgin is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgadu (PTS)squeeze (security), squeeze1:1.9.0-2+squeeze2fixed
wheezy, wheezy (security)1:1.11.2-1+deb7u2fixed
jessie, sid1:1.12.0-5fixed
pidgin (PTS)squeeze (security), squeeze2.7.3-1+squeeze4vulnerable
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
jessie, sid2.10.11-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgadusource(unstable)1:1.11.3-1high
libgadusourcesqueeze1:1.9.0-2+squeeze2highDSA-2852-1
libgadusourcewheezy1:1.11.2-1+deb7u1highDSA-2852-1
pidginsource(unstable)2.10.8-1high
pidginsourcesqueeze(unfixed)end-of-life
pidginsourcewheezy2.10.9-1~deb7u1highDSA-2859-1

Notes

[squeeze] - pidgin <end-of-life> (Support in oldstable is limited to IRC, Jabber/XMPP, Sametime and SIMPLE)

Search for package or bug name: Reporting problems